summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2021-05-06 12:34:55 +1000
committerLudovic Courtès <ludo@gnu.org>2021-05-08 14:55:50 +0200
commit3b69c308566f548cd93599e4c0871912c8e4bc18 (patch)
treecd3ce572dd358790910cef68b66c9df03139ebfb
parentf0ae715da962d47ee8eea66df27cdaddc025d268 (diff)
gnu: xfce4-session: Allow xflock4 to use xset.
* gnu/packages/xfce.scm (xfce4-session): [inputs]: Add xset. [arguments]: Add 'patch-xflock' phase to use exact store path to 'xset' in 'xflock4'. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/xfce.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index a0dcf79655..704e50e7ed 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -707,7 +707,14 @@ your system in categories, so you can quickly find and launch them.")
(list (string-append "--with-xsession-prefix=" %output))
;; Disable icon cache update.
#:make-flags
- '("gtk_update_icon_cache=true")))
+ '("gtk_update_icon_cache=true")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-xflock
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((xset (assoc-ref inputs "xset")))
+ (substitute* "scripts/xflock4"
+ (("xset") (string-append xset "/bin/xset")))))))))
(native-inputs
`(("pkg-config" ,pkg-config)
("intltool" ,intltool)))
@@ -717,7 +724,8 @@ your system in categories, so you can quickly find and launch them.")
("polkit" ,polkit)
("libsm" ,libsm)
("libwnck" ,libwnck)
- ("libxfce4ui" ,libxfce4ui)))
+ ("libxfce4ui" ,libxfce4ui)
+ ("xset" ,xset)))
(home-page "https://www.xfce.org/")
(synopsis "Xfce session manager")
(description