summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-04-20 05:22:35 +0000
committerLars-Dominik Braun <lars@6xq.net>2021-05-08 11:27:48 +0200
commit4907d70898fe94233e7f27284d5a2432a739653b (patch)
tree06eebaf5dda7fbdf940591c4b934bdba5325479e
parent30fd24641c3047484820c8a49afc7685f26ac09d (diff)
gnu: python-language-server: Enable tests.
* gnu/packages/python-xyz.scm (python-language-server): Enable tests. [arguments]: Add phases to enable tests. [propagated-inputs]: Add python-flake8.
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 07d43d05ff..ca27e45fcd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4510,10 +4510,21 @@ Server (PLS).")
(base32
"1c0pnk2aibfhfaanrs0a5gkabkvz81gj20z7r0152b7fcx5ci14r"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'set-HOME
+ (lambda _ (setenv "HOME" "/tmp") #t))
+ (replace 'check
+ (lambda _
+ ;; Disable failing test.
+ (invoke "python" "-m" "pytest" "-k"
+ "not test_pyqt_completion"))))))
(propagated-inputs
`(("python-autopep8" ,python-autopep8)
("python-configparser" ,python-configparser)
("python-pydocstyle" ,python-pydocstyle)
+ ("python-flake8" ,python-flake8)
("python-future" ,python-future)
("python-jedi" ,python-jedi)
("python-jsonrpc-server" ,python-jsonrpc-server)