summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Streit <simon@netpanic.org>2021-05-06 11:22:08 +0200
committerLudovic Courtès <ludo@gnu.org>2021-05-08 14:55:50 +0200
commit7cea32e407903d7e94da589e17b803be2fc5b05d (patch)
tree0124a5e9250bb2fb6ccb36d4d2ad3886863b8af2
parent3b69c308566f548cd93599e4c0871912c8e4bc18 (diff)
gnu: Add volctl.
* gnu/packages/gtk.scm (volctl): New Variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/gtk.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 8c8a2956ef..4883638587 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -26,6 +26,7 @@
;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -90,6 +91,7 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module (gnu packages xdisorg)
+ #:use-module (gnu packages pulseaudio)
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26)
#:use-module (ice-9 match))
@@ -2354,3 +2356,47 @@ linear or logarithmic scales, as dots or lines, with markers/labels) as well as
user interaction (e.g. measuring distances).")
(home-page "https://sourceforge.net/projects/gtkdatabox/")
(license license:lgpl2.1+)))
+
+(define-public volctl
+ (package
+ (name "volctl")
+ (version "0.8.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url "https://github.com/buzz/volctl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1cx27j83pz2qffnzb85fbl1x6pp3irv1kbw7g1hri7kaw6ky4xiz"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((pulse (assoc-ref inputs "pulseaudio"))
+ (xfixes (assoc-ref inputs "libxfixes")))
+ (substitute* "volctl/lib/xwrappers.py"
+ (("libXfixes.so")
+ (string-append xfixes "/lib/libXfixes.so")))
+ (substitute* "volctl/lib/pulseaudio.py"
+ (("libpulse.so.0")
+ (string-append pulse "/lib/libpulse.so.0")))
+ #t))))))
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("libxfixes" ,libxfixes)
+ ("pulseaudio" ,pulseaudio)))
+ (propagated-inputs
+ `(("python-click" ,python-click)
+ ("python-pycairo" ,python-pycairo)
+ ("python-pygobject" ,python-pygobject)
+ ("python-pyyaml" ,python-pyyaml)))
+ (home-page "https://buzz.github.io/volctl/")
+ (synopsis "Per-application volume control and on-screen display (OSD) for graphical desktops")
+ (description "Volctl is a PulseAudio-enabled tray icon volume control and
+OSD applet for graphical desktops. It's not meant to be an replacement for a
+full-featured mixer application. If you're looking for that check out the
+excellent pavucontrol.")
+ (license license:gpl2)))