summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-05-03 22:53:40 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-05-08 13:43:17 +0200
commite961f15083e71abfd16b74a10331c9297960370d (patch)
treea5643b100514b35fe4883b72d7139df4cf93e1ce
parent2e501ad539d9d7b7761564b94a310233619914ec (diff)
gnu: Add cl-3d-vectors.
* gnu/packages/lisp-xyz.scm (sbcl-3d-vectors, ecl-3d-vectors, cl-3d-vectors): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index d1a4aa3ab8..cdd5d7191b 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -16362,3 +16362,37 @@ for Common Lisp.")
(define-public cl-bknr-datastore
(sbcl-package->cl-source-package sbcl-bknr-datastore))
+
+(define-public sbcl-3d-vectors
+ (let ((commit "29bb9684df803590deed344af63dbf7b712aabc0")
+ (revision "1"))
+ (package
+ (name "sbcl-3d-vectors")
+ (version (git-version "3.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shinmera/3d-vectors")
+ (commit commit)))
+ (file-name (git-file-name "3d-vectors" version))
+ (sha256
+ (base32 "0qc7m5brhpwi531rgmlaj1c609by533a1ia5hv8f90ilm8ksmw3l"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ `(("parachute" ,sbcl-parachute)))
+ (inputs
+ `(("documentation-utils" ,sbcl-documentation-utils)))
+ (home-page "https://shinmera.github.io/3d-vectors/")
+ (synopsis "Utility library implementing 2D, 3D, and 4D vectors")
+ (description
+ "@code{3D-VECTORS} is a library for vector math in 3D space. It contains
+most of the vector operations one would usually expect out of such a library and
+offers them both in non-modifying and modifying versions where applicable.")
+ (license license:zlib))))
+
+(define-public ecl-3d-vectors
+ (sbcl-package->ecl-package sbcl-3d-vectors))
+
+(define-public cl-3d-vectors
+ (sbcl-package->cl-source-package sbcl-3d-vectors))