summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-29 22:20:44 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-30 04:52:09 +0200
commit0acbcaa90da1fb9ed0b1ec09d1a0c0674c99093a (patch)
treef5b4a6a042354d5d3070905ec981266c4cbaa837
parent2bed5222334ee92897a7cc57a5b65a6cc01b3244 (diff)
gnu: alpine: Update to 2.23.2.
* gnu/packages/mail.scm (alpine): Update to 2.23.2. [source]: Use new git tag.
-rw-r--r--gnu/packages/mail.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index d0c0ce663e..e1d3733e5f 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -2943,10 +2943,7 @@ operators and scripters.")
(define-public alpine
(package
(name "alpine")
- ;; Upstream doesn't use git tags, but does ‘tag’ their releases in the
- ;; commit message. Hence the lack of GIT-VERSIONing despite using a commit
- ;; ID below. Don't forget to update it…
- (version "2.22")
+ (version "2.23.2")
(source
(origin
(method git-fetch)
@@ -2956,10 +2953,10 @@ operators and scripters.")
;; http://alpine.freeiz.com/alpine/readme/README.patches
(uri (git-reference
(url "http://repo.or.cz/alpine.git")
- (commit "b50297779a4becb9ceca9c6b5b375d526fe3df78")))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "06js44fvdl7l33hfd4lsxpcd1cz3c0h796cswyzz0lkrzx89yl48"))
+ (base32 "16ldmmcymrnpnbfc1kb2rhac7nzlc87wjawic4wfinkphd124d1y"))
(modules '((guix build utils)))
(snippet
'(begin