summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2020-08-28 15:34:00 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-08-29 13:24:50 +0200
commit0ec6b8afd7e7a6c288fbf48c5779f2e0bdaffb55 (patch)
treef17045716a42015dcc4a37c6f0933f2138816951
parent62a68b738232d4570c0d5219e197431d5c15c569 (diff)
gnu: emacs: Strip double wrap.
* gnu/packages/emacs.scm (emacs)[#:phases]: Add 'strip-double-wrap. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/emacs.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index a338abc774..84c1889617 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -191,6 +191,17 @@
(rename-file real wrapper))
pdmp pdmp-real))
#t))
+ (add-after 'glib-or-gtk-wrap 'strip-double-wrap
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Directly copy emacs-X.Y to emacs, so that it is not wrapped
+ ;; twice. This also fixes a minor issue, where WMs would not be
+ ;; able to track emacs back to emacs.desktop.
+ (with-directory-excursion (assoc-ref outputs "out")
+ (copy-file (string-append
+ "bin/emacs-"
+ ,(version-major+minor (package-version emacs)))
+ "bin/emacs")
+ #t)))
(add-before 'reset-gzip-timestamps 'make-compressed-files-writable
;; The 'reset-gzip-timestamps phase will throw a permission error
;; if gzip files aren't writable then. This phase is needed when