summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2020-08-28 12:03:42 +0200
committerLeo Famulari <leo@famulari.name>2020-08-29 14:26:23 -0400
commit4aaa27e4d2d9edbd919a1e87eb8e9c0feb895444 (patch)
treeb3913e5915128fb8859c422b840dc4b57459b781
parent7683be2e3f2ec2b5b325cadc8d720917305af8de (diff)
gnu: Add hdt-cpp.
* gnu/packages/rdf.scm (hdt-cpp): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/rdf.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index e68e57818d..b1906a6145 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2020 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2020 pukkamustard <pukkamustard@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -413,3 +414,32 @@ parser and serializer.")
(description
"This package contains RDF Collections flattener for @code{rdflib}.")
(license license:asl2.0)))
+
+(define-public hdt-cpp
+ (package
+ (name "hdt-cpp")
+ (version "1.3.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rdfhdt/hdt-cpp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vsq80jnix6cy78ayag7v8ajyw7h8dqyad1q6xkf2hzz3skvr34z"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("serd" ,serd)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/rdfhdt/hdt-cpp")
+ (synopsis "C++ implementation of the HDT compression format")
+ (description "Header Dictionary Triples (HDT) is a compression format for
+RDF data that can also be queried for Triple Patterns. This package provides a
+C++ library as well as various command-line tools to to work with HDT.")
+(license license:lgpl2.1+)))