summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-30 03:11:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-30 04:52:09 +0200
commit5a9f2ae19b9d50cb8d0d94612c7bd074ce85f0c5 (patch)
tree1eb37f59d0c6a50df9cef535394acfc76edb9357
parent9925a2347a96f1125de4acee65eac064b7e02a46 (diff)
gnu: fdupes: Update to 2.1.2.
* gnu/packages/admin.scm (fdupes): Update to 2.1.2. [source]: Use bootstrapped release tarball. [arguments]: Delete field. [inputs]: Add ncurses and pcre2.
-rw-r--r--gnu/packages/admin.scm23
1 files changed, 9 insertions, 14 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 5d2c05618a..a7ecc378d5 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2133,24 +2133,19 @@ degradation and failure.")
(define-public fdupes
(package
(name "fdupes")
- (version "1.6.1")
+ (version "2.1.2")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/adrianlopezroche/fdupes")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (string-append "https://github.com/adrianlopezroche/fdupes/"
+ "releases/download/v" version "/"
+ "fdupes-" version ".tar.gz"))
(sha256
- (base32 "19b6vqblddaw8ccw4sn0qsqzbswlhrz8ia6n4m3hymvcxn8skpz9"))))
+ (base32 "1g9p50xhi2sp0hqxml4w2k0kq9jv988q2yxm347z5349dlxvap6d"))))
(build-system gnu-build-system)
- (arguments
- '(#:phases (modify-phases %standard-phases
- (delete 'configure))
- #:tests? #f ; no 'check' target
- #:make-flags (list "CC=gcc"
- (string-append "PREFIX="
- (assoc-ref %outputs "out")))))
+ (inputs
+ `(("ncurses" ,ncurses)
+ ("pcre2" ,pcre2)))
(home-page "https://github.com/adrianlopezroche/fdupes")
(synopsis "Identify duplicate files")
(description