summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-08-30 12:43:07 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-08-30 12:44:10 +0200
commit841fe2df5ea8b3342454b250e69efeed494be869 (patch)
tree6b634ec5539b7bf52492d4d66a35476f8c274fff
parente4e03047fb63101dff42be57846d43ec4f18c7a5 (diff)
gnu: emacs-js2-mode: Update to 20190219-1.40aab27.
* gnu/packages/emacs-xyz.scm (emacs-js2-mode): Update to to 20190219-1.40aab27.
-rw-r--r--gnu/packages/emacs-xyz.scm44
1 files changed, 23 insertions, 21 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c6d95d9b83..550a80b6d3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7525,31 +7525,33 @@ to all the other commands, too.")
(license license:gpl3+)))
(define-public emacs-js2-mode
- (package
- (name "emacs-js2-mode")
- (version "20190219")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mooz/js2-mode")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0766bbr4piia9vfr4ivd2gwi8dxah654adv6h28ylz4q8xmfzm1b"))))
- (build-system emacs-build-system)
- (arguments
- `(#:tests? #t
- #:test-command '("make" "test")))
- (home-page "https://github.com/mooz/js2-mode/")
- (synopsis "Improved JavaScript editing mode for Emacs")
- (description
- "Js2-mode provides a JavaScript major mode for Emacs that is more
+ (let ((commit "40aab27581279d0fdbfeb9afeb85f39d401a927f")
+ (revision "1"))
+ (package
+ (name "emacs-js2-mode")
+ (version (git-version "20190219" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mooz/js2-mode")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ysd0ji3vvk2zpjcg1wl7b2hva8471vq0ypib4h6spnpjdr43vzk"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:tests? #t
+ #:test-command '("make" "test")))
+ (home-page "https://github.com/mooz/js2-mode/")
+ (synopsis "Improved JavaScript editing mode for Emacs")
+ (description
+ "Js2-mode provides a JavaScript major mode for Emacs that is more
advanced than the built-in javascript-mode. Features include accurate syntax
highlighting using a recursive-descent parser, on-the-fly reporting of syntax
errors and strict-mode warnings, smart line-wrapping within comments and
strings, and code folding.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-nodejs-repl
(package