summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2020-08-29 22:27:09 -0500
committerBrett Gilio <brettg@gnu.org>2020-08-29 22:27:09 -0500
commitd560a2c781621a8a01bac42d3a508f165547ebde (patch)
treecd81ae2df6543fa58de5171a135c839f6b65c36c
parent73a3085e346f7e6286acdc3e7b0ea3194ff0c317 (diff)
gnu: emacs-haskell-mode: Delete test failing on Emacs 27.1.
* gnu/packages/emacs-xyz.scm (emacs-haskell-mode)[arguments]<delete-failing-tests>: Add "haskell-indent-tests.el" to list of deleted tests as it currently fails on Emacs 27.1 https://github.com/haskell/haskell-mode/issues/1714
-rw-r--r--gnu/packages/emacs-xyz.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ff789ffedf..c6d95d9b83 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -959,8 +959,13 @@ replacement.")
;; native input.
(lambda _
(with-directory-excursion "tests"
+ ;; File `haskell-indent-tests.el' fails with
+ ;; `haskell-indent-put-region-in-literate-2'
+ ;; on Emacs 27.1+
+ ;; XXX: https://github.com/haskell/haskell-mode/issues/1714
(for-each delete-file
- '("haskell-customize-tests.el"
+ '("haskell-indent-tests.el"
+ "haskell-customize-tests.el"
"inferior-haskell-tests.el")))
#t))
(replace 'install