summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Hill <jackhill@jackhill.us>2023-12-21 00:33:08 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2023-12-21 12:34:56 -0500
commit04b63ea195cbcbcf519b7dd52546c6d56be6741b (patch)
tree6515e62ab4d17b0d98ff58da9d4973c829ed27ef
parent97e517a5682af0fc031a5b7b1abf6d7c6ec2b2c9 (diff)
gnu: openssh: Update to 9.6p1 [security-fixes].
Fixes CVE-2023-48795. * gnu/packages/ssh.scm (openssh): Update to 9.6p1. [arguments]<#:parallel-tests?>: Disable. Change-Id: I8b7707894d904ec8bcccb943908fff2e69a1a027 Signed-off-by: John Kehayias <john.kehayias@protonmail.com>
-rw-r--r--gnu/packages/ssh.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 79ec702ebf..0b364bbe90 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -198,7 +198,7 @@ a server that supports the SSH-2 protocol.")
(define-public openssh
(package
(name "openssh")
- (version "9.5p1")
+ (version "9.6p1")
(source
(origin
(method url-fetch)
@@ -206,11 +206,14 @@ a server that supports the SSH-2 protocol.")
"openssh-" version ".tar.gz"))
(patches (search-patches "openssh-trust-guix-store-directory.patch"))
(sha256
- (base32 "0sq8hqk6f0x6djgvqawjbwwxpwd8r1nzjahqfl7m9yx7kfvyf9ph"))))
+ (base32 "0z3pgam8b4z05lvdb78iv06p204qwl7b94a3cnnwba2mfb0120li"))))
(build-system gnu-build-system)
(arguments
(list
#:test-target "tests"
+ ;; Not all of the tests can be run in parallel, see
+ ;; <https://marc.info/?l=openssh-unix-dev&m=170313565518842>.
+ #:parallel-tests? #f
;; Otherwise, the test scripts try to use a nonexistent directory and fail.
#:make-flags
#~(list "REGRESSTMP=\"$${BUILDDIR}/regress\"")