summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-04-21 02:03:58 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-21 14:01:25 +0200
commit184658e282d5e16beb4e30440afffd7f9b392021 (patch)
tree7ea30d742b1dda0248383a3bcc3b75b0631c3e83
parent2a20acf24b964e527b69f8b1111a3fdee1a56f68 (diff)
gnu: bppsuite: Update to 2.4.1.
* gnu/packages/bioinformatics.scm (bppsuite): Update to 2.4.1. [source]: Remove the commit and use the release version. Changed to the github repo. [arguments]: Remove the disabled parallel-build. [inputs]: Use list. [home-page]: Changed to github page.
-rw-r--r--gnu/packages/bioinformatics.scm56
1 files changed, 24 insertions, 32 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 152cef2e01..8813bbe308 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2367,40 +2367,32 @@ It is part of the Bio++ project.")
(license license:cecill)))
(define-public bppsuite
- ;; The last release was in 2014 and the recommended way to install from source
- ;; is to clone the git repository, so we do this.
- ;; http://biopp.univ-montp2.fr/wiki/index.php/Main_Page
- (let ((commit "c516147f57aa50961121cd505bed52cd7603698b"))
- (package
- (name "bppsuite")
- (version (string-append "2.2.0-1." (string-take commit 7)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "http://biopp.univ-montp2.fr/git/bppsuite")
- (commit commit)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "1y87pxvw0jxjizhq2dr9g2r91md45k1p9ih2sl1yy1y3p934l2kb"))))
- (build-system cmake-build-system)
- (arguments
- `(#:parallel-build? #f
- #:tests? #f)) ; There are no tests.
- (native-inputs
- (list groff man-db texinfo))
- (inputs
- `(("bpp-core" ,bpp-core)
- ("bpp-seq" ,bpp-seq)
- ("bpp-phyl" ,bpp-phyl)
- ("bpp-phyl" ,bpp-popgen)))
- (home-page "http://biopp.univ-montp2.fr")
- (synopsis "Bioinformatics tools written with the Bio++ libraries")
- (description
- "Bio++ is a set of C++ libraries for Bioinformatics, including sequence
+ (package
+ (name "bppsuite")
+ (version "2.4.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/BioPP/bppsuite")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1wdwcgczqbc3m116vakvi0129wm3acln3cfc7ivqnalwvi6lrpds"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f)) ; There are no tests.
+ (native-inputs
+ (list groff man-db texinfo))
+ (inputs
+ (list bpp-core bpp-seq bpp-phyl bpp-popgen))
+ (home-page "https://github.com/BioPP")
+ (synopsis "Bioinformatics tools written with the Bio++ libraries")
+ (description
+ "Bio++ is a set of C++ libraries for Bioinformatics, including sequence
analysis, phylogenetics, molecular evolution and population genetics. This
package provides command line tools using the Bio++ library.")
- (license license:cecill-c))))
+ (license license:cecill-c)))
(define-public blast+
(package