summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2023-09-01 09:51:33 +0400
committerAndrew Tropin <andrew@trop.in>2023-09-01 23:08:51 +0400
commit1936f38d6d6e5e16bc20382049cdab0c0cf23e22 (patch)
treecbcf341995f8b0a3ae3b248573d31614a38af9e6
parenta88da4199c30291a3155ff1b24b4b5ab3d7c40c0 (diff)
gnu: tree-sitter-grammar: Add get-cleanup-snippet argument.
* gnu/packages/tree-sitter.scm (tree-sitter-grammar): Add get-cleanup-snippet argument.
-rw-r--r--gnu/packages/tree-sitter.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/tree-sitter.scm b/gnu/packages/tree-sitter.scm
index 55f45d3c45..f81658d8de 100644
--- a/gnu/packages/tree-sitter.scm
+++ b/gnu/packages/tree-sitter.scm
@@ -271,11 +271,14 @@ This package includes the @command{tree-sitter} command-line tool.")
(grammar-directories '("."))
(article "a")
(inputs '())
+ (get-cleanup-snippet tree-sitter-delete-generated-files)
(license license:expat))
"Returns a package for Tree-sitter grammar. NAME will be used with
tree-sitter- prefix to generate package name and also for generating
REPOSITORY-URL value if it's not specified explicitly, TEXT is a string which
-will be used in description and synopsis."
+will be used in description and synopsis. GET-CLEANUP-SNIPPET is a function,
+it recieves GRAMMAR-DIRECTORIES as an argument and should return a G-exp,
+which will be used as a snippet in origin."
(let* ((multiple? (> (length grammar-directories) 1))
(grammar-names (string-append text " grammar" (if multiple? "s" "")))
(synopsis (string-append "Tree-sitter " grammar-names))
@@ -296,7 +299,7 @@ will be used in description and synopsis."
(file-name (git-file-name name version))
(sha256 (base32 hash))
(snippet
- (tree-sitter-delete-generated-files grammar-directories))))
+ (get-cleanup-snippet grammar-directories))))
(build-system tree-sitter-build-system)
(arguments (list #:grammar-directories grammar-directories))
(inputs inputs)