summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-03-10 19:35:14 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-21 23:50:26 +0000
commit27b339702f601d2635416111930843a32dd625ed (patch)
tree031095361b6ca896ee64268ef7d5c79dd7ca7bc1
parent8d27fe61d7f1a2bed0367fa861e4cae1f2f1546d (diff)
gnu: Add go-github-com-hashicorp-go-hclog.
* gnu/packages/golang-xyz.scm (go-github-com-hashicorp-go-hclog): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/golang-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 5c6e74870b..0a7126f349 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -901,6 +901,40 @@ expressing configuration which is easy for both humans and machines to read.")
(home-page "https://github.com/hashicorp/hcl")
(license license:mpl2.0)))
+(define-public go-github-com-hashicorp-go-hclog
+ (package
+ (name "go-github-com-hashicorp-go-hclog")
+ (version "1.6.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hashicorp/go-hclog")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1lvr4ga95a0xb62vgq1hy558x3r65hn2d0h7bf0a88lsfsrcik0n"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/hashicorp/go-hclog"))
+ (propagated-inputs
+ (list go-github-com-fatih-color
+ go-github-com-mattn-go-isatty
+ go-golang-org-x-tools))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/hashicorp/go-hclog")
+ (synopsis "Key/value logging interface for Go")
+ (description
+ "This package provides a simple key/value logging interface for Golang
+for use in development and production environments. Unlike the standard
+library @code{log} package, this package provides logging levels that provide
+decreased output based upon the desired amount of output. It also comes with
+a command-line program @code{hclogvet} that can be used to check that the logging level
+methods on @code{hclog.Logger} are used correctly.")
+ (license license:expat)))
+
(define-public go-github-com-hashicorp-go-multierror
(package
(name "go-github-com-hashicorp-go-multierror")