summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Eure <ian@retrospec.tv>2024-02-25 14:20:31 -0800
committerAndreas Enge <andreas@enge.fr>2024-03-07 20:28:52 +0100
commit34d7fa58edce071292050a3553081bcd3b5e180e (patch)
tree49e3da5f0014e13803b1ed00bb93617362a9c0d0
parent2c5be45f3a3b1a60b3f5b2e02bc7f2f71b461c3b (diff)
gnu: Add python-jellyfin-apiclient.
* gnu/packages/python-xyz.scm (python-jellyfin-apiclient): New variable. Change-Id: If84546b14d380a3a10af63d4f41711125298487a Signed-off-by: Andreas Enge <andreas@enge.fr>
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 55fd4cdad2..b9c9b9da16 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25954,6 +25954,26 @@ submitting it.")
python-mpv, but it uses the JSON IPC protocol instead of the C API.")
(license license:asl2.0)))
+(define-public python-jellyfin-apiclient
+ (package
+ (name "python-jellyfin-apiclient")
+ (version "1.9.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jellyfin-apiclient-python" version))
+ (sha256
+ (base32 "0r67cp9nizvn3cbslgi30zpd3mw4a6zal0ygik3jv5lni1xdkk5w"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-certifi python-requests python-urllib3
+ python-websocket-client))
+ (home-page "https://github.com/jellyfin/jellyfin-apiclient-python")
+ (synopsis "Python API client for Jellyfin")
+ (description "The Jellyfin ApiClient Python package makes it possible
+to use the Jellyfin API from Python. It was extracted from the Jellyfin
+Kodi plugin.")
+ (license license:gpl3+)))
+
(define-public python-parso
(package
(name "python-parso")