summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-01-17 00:07:42 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-02 16:56:32 +0000
commit34e8a40dadc1169d4810fa5111a9eaaadedeb66f (patch)
tree820f0488b8653daeeacecd8bfe16f01fa1fdcf21
parentf2e5e94544fdd16d681046cf80bafa7aa13c1f27 (diff)
gnu: Add go-github-com-gregjones-httpcache.
* gnu/packages/golang-web.scm (go-github-com-gregjones-httpcache): New variable. Change-Id: I2ba0196fd1de63f26a814dc96ff64a6fb5379043 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/golang-web.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index f11e59ce48..c66b93cb84 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -22,7 +22,7 @@
;;; Copyright © 2023 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2023 Thomas Ieong <th.ieong@free.fr>
-;;; Copyright © 2023 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2023, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -907,6 +907,34 @@ sessions, flash messages, custom backends, and more.")
protocol.")
(license license:bsd-2)))
+(define-public go-github-com-gregjones-httpcache
+ (let ((commit "901d90724c7919163f472a9812253fb26761123d")
+ (revision "0"))
+ (package
+ (name "go-github-com-gregjones-httpcache")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gregjones/httpcache")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05r0xq51vfb55di11m7iv19341d73f7in33vq1ihcqs1nffdwiq0"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/gregjones/httpcache"))
+ (home-page "https://github.com/gregjones/httpcache")
+ (synopsis "Transport for @code{http.Client} that will cache responses")
+ (description
+ "Package @code{httpcache} provides a @code{http.RoundTripper}
+implementation that works as a mostly @url{https://tools.ietf.org/html/rfc7234, RFC 7234}
+compliant cache for HTTP responses. It is only suitable for use as a
+\"private\" cache (i.e. for a web-browser or an API-client and not for a
+shared proxy).")
+ (license license:expat))))
+
(define-public go-github-com-hjson-hjson-go
(package
(name "go-github-com-hjson-hjson-go")