summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-22 12:52:36 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-22 13:02:44 +0300
commit55df233474cde107b5a33caa3ea6fca822a6298a (patch)
treee3fffdb96634ac37ff757425bd263a8b304bf177
parent0c83d17d891aeeff8d908422edefa74cb2c1125a (diff)
gnu: rust-expect-test-1: Update to 1.4.1.
* gnu/packages/crates-io.scm (rust-expect-test-1): Update to 1.4.1. [arguments]: Don't skip tests.
-rw-r--r--gnu/packages/crates-io.scm18
1 files changed, 6 insertions, 12 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index cf1e050e69..902fc73542 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -24410,27 +24410,21 @@ by @file{sysexits.h}.")
(define-public rust-expect-test-1
(package
(name "rust-expect-test")
- (version "1.2.2")
+ (version "1.4.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "expect-test" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32
- "05nv365xd5fqydmzbsvzqz0148a1vbxp2p0r8a3ivafdvhl6ngky"))))
+ (base32 "1lzqx5hqh1g4llzqby4z1d18xmrjjx63c5l0na7ycf6mmpzfmn9h"))))
(build-system cargo-build-system)
(arguments
- `(#:skip-build?
- #t
- #:cargo-inputs
+ `(#:cargo-inputs
(("rust-dissimilar" ,rust-dissimilar-1)
("rust-once-cell" ,rust-once-cell-1))))
- (home-page
- "https://github.com/rust-analyzer/expect-test")
- (synopsis
- "Minimalistic snapshot testing library")
+ (home-page "https://github.com/rust-analyzer/expect-test")
+ (synopsis "Minimalistic snapshot testing library")
(description
"This package provides a minimalistic snapshot testing library.")
(license (list license:expat license:asl2.0))))