summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-02 19:22:13 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-02 19:22:13 +0100
commit5b030de3866f450209f39079abe63a5fbcb719a0 (patch)
tree44ef65a8fb60d68eb094b27142f65ae2ec0fd909
parentf1bf43cdff9a06d91f4598c90203c685a908f624 (diff)
gnu: Add r-epidish.
* gnu/packages/bioconductor.scm (r-epidish): New variable. Change-Id: Ib8ca5980149a5d3eabb3d4a68ae686b855e372d4
-rw-r--r--gnu/packages/bioconductor.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 427fa4ebfe..72a0fe377f 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -7462,6 +7462,37 @@ chromosome region or transcript models of lincRNA genes.")
;; No version specified
(license license:lgpl3+)))
+(define-public r-epidish
+ (package
+ (name "r-epidish")
+ (version "2.18.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "EpiDISH" version))
+ (sha256
+ (base32 "170ym3y6gd1kxghz2g5ynvgi1wrxx87b568cjcvzidpqkrkg87s6"))))
+ (properties `((upstream-name . "EpiDISH")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-e1071
+ r-locfdr
+ r-mass
+ r-matrix
+ r-matrixstats
+ r-quadprog
+ r-stringr))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/sjczheng/EpiDISH")
+ (synopsis "Epigenetic dissection of intra-sample-heterogeneity")
+ (description
+ "@code{EpiDISH} is a R package to infer the proportions of a priori known
+cell-types present in a sample representing a mixture of such cell-types.
+Right now, the package can be used on DNAm data of whole blood, generic
+epithelial tissue and breast tissue. Besides, the package provides a function
+that allows the identification of differentially methylated cell-types and
+their directionality of change in Epigenome-Wide Association Studies.")
+ (license license:gpl2)))
+
(define-public r-fastseg
(package
(name "r-fastseg")