summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-13 12:10:53 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:46 +0200
commit5c7700fc051b28bf9e8eb4a16f68f4a7c50152cb (patch)
tree2c3926198ec737d4ce150977c04325beafe00ca7
parent9550a203618ff3cbc20381b1ac65b5ab7422661a (diff)
gnu: texlive-latex-anysize -> texlive-anysize.
* gnu/packages/tex.scm (texlive-anysize): New variable. (texlive-latex-anysize): Deprecate variable. * gnu/packages/docbook.scm (dblatex): Use new name.
-rw-r--r--gnu/packages/docbook.scm2
-rw-r--r--gnu/packages/tex.scm38
2 files changed, 14 insertions, 26 deletions
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index 070b957339..86c130860c 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -535,7 +535,7 @@ the in DocBook SGML DTDs.")
;; TODO: Add xfig/transfig for fig2dev utility
(inputs
`(("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts
- texlive-latex-anysize
+ texlive-anysize
texlive-latex-appendix
texlive-latex-bookmark
texlive-latex-changebar
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3b5b3d2db3..b496dab8fd 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6443,33 +6443,19 @@ does not affect @code{\\tt}, @code{\\texttt}, etc.")
(define-deprecated-package texlive-latex-upquote texlive-upquote)
-(define-public texlive-latex-anysize
+(define-public texlive-anysize
(package
- (name "texlive-latex-anysize")
+ (name "texlive-anysize")
(version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/tex/latex/anysize"))
- (revision %texlive-revision)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "19khwqjlvznc955sijhww3c4zbb0053rvzwv9nz738qknq7y18vb"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let ((target (string-append (assoc-ref %outputs "out")
- "/share/texmf-dist/tex/latex/anysize")))
- (mkdir-p target)
- (copy-recursively (assoc-ref %build-inputs "source") target)
- #t))))
- (home-page "https://www.ctan.org/pkg/anysize")
+ (source (texlive-origin
+ name version
+ (list "doc/latex/anysize/"
+ "tex/latex/anysize/")
+ (base32
+ "155s0v82zpkmv97kwqhhfw52230hka9zl3wzjw1d5ayxd4n11bxq")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/anysize")
(synopsis "Simple package to set up document margins")
(description
"This is a simple package to set up document margins. This package is
@@ -6477,6 +6463,8 @@ considered obsolete; alternatives are the @code{typearea} package from the
@code{koma-script} bundle, or the @code{geometry} package.")
(license license:public-domain)))
+(define-deprecated-package texlive-latex-anysize texlive-anysize)
+
(define-public texlive-latex-appendix
(package
(name "texlive-latex-appendix")