summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-04-21 10:16:40 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-21 12:56:39 +0200
commit7c75228c8ba4aaeb8935e9d49db514749cb79f06 (patch)
tree38508c8bed6d14c02182f7d75902470c8fae49b3
parent722a8b2296e32f7ef510bf877c36d30b2ef621b5 (diff)
gnu: Add bpp-phyl-omics.
* gnu/packages/bioinformatics.scm (bpp-phyl-omics): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 576af31ae6..511431fb95 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2267,6 +2267,34 @@ analysis, phylogenetics, molecular evolution and population genetics. This
library provides phylogenetics-related modules.")
(license license:cecill-c)))
+(define-public bpp-phyl-omics
+ (package
+ (name "bpp-phyl-omics")
+ (version "2.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/BioPP/bpp-phyl-omics")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "172psb8njkjwg3cd6gdy5w0mq8f0817v635yw4bk7146aggjzl1h"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f)) ; No test provided.
+ (inputs
+ (list bpp-core
+ bpp-phyl
+ bpp-seq
+ bpp-seq-omics))
+ (home-page "https://github.com/BioPP/bpp-phyl-omics")
+ (synopsis "Bio++ phylogenetic library genomics components")
+ (description
+ "This library contains the genomics components of the Bio++ phylogenetics
+library. It is part of the Bio++ project.")
+ (license license:cecill)))
+
(define-public bpp-popgen
;; The last release was in 2014 and the recommended way to install from source
;; is to clone the git repository, so we do this.