summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundationdevices.com>2023-07-28 14:23:59 +0200
committerVagrant Cascadian <vagrant@debian.org>2023-08-29 17:12:49 -0700
commita012881e158cca32d9e167e8364796b84ff349b0 (patch)
treeada8e11873c8b4b7c6f8e3871944f563cf820aee
parent3080d0d8d714dd066970bd0a4b684150dcdbe67b (diff)
gnu: Add python-halo.
* gnu/packages/terminals.scm (python-halo): New variable. Signed-off-by: Jean-Pierre De Jesus DIAZ <jean@foundationdevices.com> Signed-off-by: Vagrant Cascadian <vagrant@debian.org>
-rw-r--r--gnu/packages/terminals.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index f3e81fb65b..43aeac9fd7 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -1160,6 +1160,27 @@ terminal. It features string-like objects which carry formatting information,
per-line fullscreen terminal rendering, and keyboard input event reporting.")
(license license:expat)))
+(define-public python-halo
+ (package
+ (name "python-halo")
+ (version "0.0.31")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "halo" version))
+ (sha256
+ (base32
+ "1mn97h370ggbc9vi6x8r6akd5q8i512y6kid2nvm67g93r9a6rvv"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-colorama python-log-symbols python-six
+ python-spinners python-termcolor))
+ (native-inputs (list python-coverage python-nose python-pylint python-tox
+ python-twine))
+ (home-page "https://github.com/manrajgrover/halo")
+ (synopsis "Python library to display graphical spinners in the terminal")
+ (description "Halo is a Python library to display graphical spinners in
+the terminal. It also supports IPython/Jupyter.")
+ (license license:expat)))
+
(define-public python-log-symbols
(package
(name "python-log-symbols")