summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-10-03 20:22:35 +0800
committerHilton Chain <hako@ultrarare.space>2023-10-03 20:25:53 +0800
commita71232b2c51b38bd2335e209344aa0cbfd192969 (patch)
tree631875c41632b0c7a6deca6ec4acad0ee4c1b34c
parent99a46ecb2647148f64da3c7e4bd6bfee3b89cdd4 (diff)
Revert "gnu: emacs-buttercup: Fix native comp tests with emacs-next."
This reverts commit e45f9b4b1251df1a51a30e1d4a53fc2075abfcfe, which doesn't fix the test issue.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/emacs-xyz.scm4
-rw-r--r--gnu/packages/patches/emacs-buttercup-fix-native-comp-pretty-test.patch32
3 files changed, 1 insertions, 36 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 512d147ef3..83b5268c7e 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1095,7 +1095,6 @@ dist_patch_DATA = \
%D%/packages/patches/elm-reactor-static-files.patch \
%D%/packages/patches/elogind-fix-rpath.patch \
%D%/packages/patches/emacs-all-the-icons-remove-duplicate-rs.patch \
- %D%/packages/patches/emacs-buttercup-fix-native-comp-pretty-test.patch \
%D%/packages/patches/emacs-deferred-fix-number-of-arguments.patch \
%D%/packages/patches/emacs-exec-path.patch \
%D%/packages/patches/emacs-ess-fix-obsolete-function-alias.patch \
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9cb64e7e1c..2e0b094d85 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -28521,9 +28521,7 @@ targets the Emacs based IDEs (CIDER, ESS, Geiser, Robe, SLIME etc.)")
(file-name (git-file-name name version))
(sha256
(base32
- "1rvc9r6swb74lhzd877jidkkf2cxl5v4zz302j2imqhsbk844qzh"))
- (patches
- (search-patches "emacs-buttercup-fix-native-comp-pretty-test.patch"))))
+ "1rvc9r6swb74lhzd877jidkkf2cxl5v4zz302j2imqhsbk844qzh"))))
(build-system emacs-build-system)
(arguments
(list
diff --git a/gnu/packages/patches/emacs-buttercup-fix-native-comp-pretty-test.patch b/gnu/packages/patches/emacs-buttercup-fix-native-comp-pretty-test.patch
deleted file mode 100644
index 677d5e2303..0000000000
--- a/gnu/packages/patches/emacs-buttercup-fix-native-comp-pretty-test.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 0f822190360a99bac6b532058beb5e20cb2673c3 Mon Sep 17 00:00:00 2001
-From: Nicolas Graves <ngraves@ngraves.fr>
-Date: Sun, 1 Oct 2023 20:20:03 +0200
-Subject: [PATCH] test: Change `pretty' test regexp to pass tests on emacs 30.
-
----
- tests/test-buttercup.el | 12 +++++++++---
- 1 file changed, 9 insertions(+), 3 deletions(-)
-
-diff --git a/tests/test-buttercup.el b/tests/test-buttercup.el
-index d68787b..a2e3ba7 100644
---- a/tests/test-buttercup.el
-+++ b/tests/test-buttercup.el
-@@ -2009,9 +2009,15 @@ text properties using `ansi-color-apply'."
- "suite bc-bt-backtrace\n"
- "\n"
- "Traceback (most recent call last):\n"
-- "λ (bc-bt-foo \"" (regex ,long-string) "\")\n"
-- "λ (bc-bt-bar \"" (regex ,long-string) "\")\n"
-- "λ (bc-bt-baz \"" (regex ,long-string) "\")\n"
-+ (seq
-+ "λ (bc-bt-foo \"" (regex ,long-string) "\")"
-+ (optional "\n"))
-+ (seq
-+ "λ (bc-bt-bar \"" (regex ,long-string) "\")"
-+ (optional "\n"))
-+ (seq
-+ "λ (bc-bt-baz \"" (regex ,long-string) "\")"
-+ (optional "\n"))
- (* (seq (or ?M ?λ) " (" (* not-newline) ; frame start
- (*? (seq "\n " (* not-newline))) ; any number of pp lines
- (* not-newline) ")\n")) ;; frame end