summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundationdevices.com>2023-07-28 14:24:01 +0200
committerVagrant Cascadian <vagrant@debian.org>2023-08-29 17:12:54 -0700
commita8f881d9b354ed46058477ae807cc601060bed1e (patch)
tree3a6f19cacaa28e52650093daa4e7ea9b8e4458e0
parentb3cee1c7e86601bae6dbd3beed566ecefa25f626 (diff)
gnu: Add python-dotty-dict.
* gnu/packages/python-xyz.scm (python-dotty-dict): New variable. Signed-off-by: Jean-Pierre De Jesus DIAZ <jean@foundationdevices.com> Signed-off-by: Vagrant Cascadian <vagrant@debian.org>
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8df0bb6106..b3b03dd700 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -626,6 +626,25 @@ hierarchy creation, can be initialized with keys, can be initialized from a
dictionary, can be convert to a dictionary, and is ordered by insertion.")
(license license:expat)))
+(define-public python-dotty-dict
+ (package
+ (name "python-dotty-dict")
+ (version "1.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "dotty_dict" version))
+ (sha256
+ (base32
+ "058sah2nyg44xq5wxywlzc3abzcv9fifnlvsflwma9mfp01nw0ab"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-poetry-core))
+ (home-page "https://github.com/pawelzny/dotty_dict")
+ (synopsis "Python library for accessing dictionaries using a dot syntax")
+ (description "This package provides a library that wraps the traditional
+Python dictionaries and provides a syntax to access nested dictionaries values
+using a dot syntax, for example: @code{dictionary['deeply.nested.key']}.")
+ (license license:expat)))
+
(define-public python-twodict
(package
(name "python-twodict")