summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-02-17 14:17:55 -0500
committerLeo Famulari <leo@famulari.name>2023-02-17 14:49:13 -0500
commitabe7afb17ced298743f3eca2fa156d480fdd038d (patch)
tree733e5ae8bd843f405c4f9af243ad16b6c330f20c
parent7eb3eec4dacc414a6680a97bc6ef38c1f76b947e (diff)
gnu: Make nothing depend on QtWebKit.
This is required for <https://issues.guix.gnu.org/53289>. * gnu/packages/qt.scm (python-pyqt)[inputs]: Remove qtwebkit. (python-pyqt-without-qtwebkit): Remove variable. (python-pyqtwebengine)[inputs]: Replace python-pyqt-without-qtwebkit with python-pyqt. * gnu/packages/backup.scm (vorta)[inputs]: Likewise. * gnu/packages/ebook.scm (calibre)[inputs]: Likewise. [arguments]: Adjust accordingly. * gnu/packages/education.scm (anki)[inputs]: Replace python-pyqt-without-qtwebkit with python-pyqt. * gnu/packages/kde-games.scm (kajongg)[inputs]: Likewise. * gnu/packages/maths.scm (veusz)[inputs]: Likewise. * gnu/packages/music.scm (frescobaldi)[inputs]: Likewise. (picard)[inputs]: Likewise. * gnu/packages/orange.scm (orange)[inputs]: Likewise. * gnu/packages/pdf.scm (flyer-composer)[inputs]: Likewise. * gnu/packages/python-check.scm (python-pytest-qt)[propagated-inputs]: Likewise. * gnu/packages/python-xyz.scm (python-qtconsole)[propagated-inputs]: Likewise. (python-pyqtgraph)[propagated-inputs]: Likewise. * gnu/packages/radio.scm (gnuradio)[inputs]: Likewise. * gnu/packages/video.scm (openshot)[inputs]: Likewise. * gnu/packages/vpn.scm (openconnect-sso)[inputs]: Likewise. * gnu/packages/web-browsers.scm (qutebrowser)[inputs]: Likewise.
-rw-r--r--gnu/packages/backup.scm2
-rw-r--r--gnu/packages/ebook.scm4
-rw-r--r--gnu/packages/education.scm2
-rw-r--r--gnu/packages/kde-games.scm2
-rw-r--r--gnu/packages/maths.scm2
-rw-r--r--gnu/packages/music.scm4
-rw-r--r--gnu/packages/orange.scm2
-rw-r--r--gnu/packages/pdf.scm2
-rw-r--r--gnu/packages/python-check.scm2
-rw-r--r--gnu/packages/python-xyz.scm4
-rw-r--r--gnu/packages/qt.scm14
-rw-r--r--gnu/packages/radio.scm2
-rw-r--r--gnu/packages/video.scm2
-rw-r--r--gnu/packages/vpn.scm2
-rw-r--r--gnu/packages/web-browsers.scm2
15 files changed, 18 insertions, 30 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 5841c894d1..8a25d0d116 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -1343,7 +1343,7 @@ borgmatic is powered by borg.")
python-paramiko
python-peewee
python-psutil
- python-pyqt-without-qtwebkit
+ python-pyqt
python-secretstorage
;; This is included so that the qt-wrap phase picks it up.
qtsvg-5))
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index b21fcfdc9a..6d645fba38 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -200,7 +200,7 @@ with Microsoft Compiled HTML (CHM) files")
python-pychm
python-pycryptodome
python-pygments
- python-pyqt-without-qtwebkit
+ python-pyqt
python-pyqtwebengine
python-regex
speech-dispatcher
@@ -246,7 +246,7 @@ tags = [\"WS_X11\"]")
(string-append "[tool.sip.project]
sip-include-dirs = [\""
#$(this-package-input
- "python-pyqt-without-qtwebkit")
+ "python-pyqt")
"/share/sip\"]")))
(substitute* "src/calibre/ebooks/pdf/pdftohtml.py"
(("PDFTOHTML = 'pdftohtml'")
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 62c4d2352d..53710f424e 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -805,7 +805,7 @@ stored and user can review his performance in any time.")
("python-pyaudio" ,python-pyaudio)
;; `python-pyqtwebengine' must precede `python-pyqt' in PYTHONPATH.
("python-pyqtwebengine" ,python-pyqtwebengine)
- ("python-pyqt" ,python-pyqt-without-qtwebkit)
+ ("python-pyqt" ,python-pyqt)
("python-requests" ,python-requests)
("python-send2trash" ,python-send2trash)
("python-sip" ,python-sip)
diff --git a/gnu/packages/kde-games.scm b/gnu/packages/kde-games.scm
index b0df2cf3d2..9be889f6aa 100644
--- a/gnu/packages/kde-games.scm
+++ b/gnu/packages/kde-games.scm
@@ -322,7 +322,7 @@ This package is part of the KDE games module.")
ki18n
libkmahjongg
python
- python-pyqt-without-qtwebkit
+ python-pyqt
python-twisted
python-qtpy
python-zope-interface
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 0da47943fd..ceb2f14a80 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3184,7 +3184,7 @@ ASCII text files using Gmsh's own scripting language.")
(list ghostscript ;optional, for EPS/PS output
python-dbus
python-h5py ;optional, for HDF5 data
- python-pyqt-without-qtwebkit
+ python-pyqt
qtbase-5
qtsvg-5))
(propagated-inputs
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 6fb2824483..59f295cc14 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2967,7 +2967,7 @@ using a system-independent interface.")
python-ly
python-poppler-qt5
python-pyportmidi
- python-pyqt-without-qtwebkit
+ python-pyqt
python-sip))
(home-page "https://www.frescobaldi.org/")
(synopsis "LilyPond sheet music text editor")
@@ -3709,7 +3709,7 @@ event-based scripts for scrobbling, notifications, etc.")
(inputs
(list chromaprint
python-discid
- python-pyqt-without-qtwebkit
+ python-pyqt
python-mutagen
python-fasteners
python-pyyaml
diff --git a/gnu/packages/orange.scm b/gnu/packages/orange.scm
index 0b8a642014..2a66fe429e 100644
--- a/gnu/packages/orange.scm
+++ b/gnu/packages/orange.scm
@@ -160,7 +160,7 @@ GUI based workflow. It is primarily used in the Orange framework.")
python-orange-widget-base
python-pandas
python-pygments
- python-pyqt-without-qtwebkit
+ python-pyqt
python-pyqtgraph
python-pyqtwebengine
python-pyyaml
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 378b1b2411..f0aefb39e8 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -185,7 +185,7 @@ information.")
(inputs
(list python-poppler-qt5
python-pypdf2
- python-pyqt-without-qtwebkit
+ python-pyqt
qtbase-5))
(home-page "http://crazy-compilers.com/flyer-composer")
(synopsis "Rearrange PDF pages to print as flyers on one sheet")
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 41ed6e9a73..04c369b482 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1678,7 +1678,7 @@ libraries.")
(setenv "QT_QPA_PLATFORM" "offscreen")
#t)))))
(propagated-inputs
- (list python-pyqt-without-qtwebkit))
+ (list python-pyqt))
(native-inputs
(list python-pytest python-pytest-runner python-setuptools-scm))
(home-page "https://github.com/pytest-dev/pytest-qt")
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cfeb37eea1..f97faefc65 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14227,7 +14227,7 @@ Jupyter kernels such as IJulia and IRKernel.")
(("def test_other_output") "def _test_other_output")))))))
(propagated-inputs
(list python-ipykernel python-ipython-genutils python-jupyter-client
- python-jupyter-core python-pygments python-pyqt-without-qtwebkit
+ python-jupyter-core python-pygments python-pyqt
python-pyzmq python-qtpy python-traitlets))
(native-inputs
(list python-flaky python-pytest python-pytest-qt))
@@ -16198,7 +16198,7 @@ ISO 8859, etc.).")
(list qtbase-5))
(propagated-inputs
(list python-h5py python-numpy python-pyopengl python-scipy
- python-pyqt-without-qtwebkit))
+ python-pyqt))
(home-page "https://www.pyqtgraph.org")
(synopsis "Scientific graphics and GUI library for Python")
(description
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index da18395efc..cad07ea19d 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -3270,7 +3270,6 @@ module provides support functions to the automatically generated code.")
("qtsvg-5" ,qtsvg-5)
("qttools-5" ,qttools-5)
("qtwebchannel-5" ,qtwebchannel-5)
- ("qtwebkit" ,qtwebkit)
("qtwebsockets-5" ,qtwebsockets-5)
("qtx11extras" ,qtx11extras)
("qtxmlpatterns" ,qtxmlpatterns)))
@@ -3367,7 +3366,7 @@ contain over 620 classes.")
(inputs
`(("python" ,python-wrapper)
("python-sip" ,python-sip)
- ("python-pyqt" ,python-pyqt-without-qtwebkit)
+ ("python-pyqt" ,python-pyqt)
("qtbase" ,qtbase-5)
("qtsvg-5" ,qtsvg-5)
("qtdeclarative-5" ,qtdeclarative-5)
@@ -3425,17 +3424,6 @@ set of three modules. Prior to v5.12 these bindings were part of PyQt
itself.")
(license license:gpl3)))
-;; XXX: This is useful for removing qtwebkit from other packages' dependency
-;; graphs, as well as for preventing python-pyqtwebengine from transitively
-;; depending on qtwebkit.
-;; Ultimately, it would be nicer to have a more modular set of python-pyqt-*
-;; packages that could be used together.
-(define-public python-pyqt-without-qtwebkit
- (package/inherit python-pyqt
- (name "python-pyqt-without-qtwebkit")
- (inputs
- (alist-delete "qtwebkit" (package-inputs python-pyqt)))))
-
(define-public python-pyqt-builder
(package
(name "python-pyqt-builder")
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 06011b03de..b9612ffd56 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -687,7 +687,7 @@ used by RDS Spy, and audio files containing @dfn{multiplex} signals (MPX).")
python-numpy
python-pycairo
python-pygobject
- python-pyqt-without-qtwebkit
+ python-pyqt
python-pyqtgraph
python-pyyaml
qtbase-5
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index df70ed6473..0697b18f3b 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -4872,7 +4872,7 @@ API. It includes bindings for Python, Ruby, and other languages.")
font-dejavu
libopenshot
python
- python-pyqt-without-qtwebkit
+ python-pyqt
python-pyqtwebengine
python-pyzmq
python-requests
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index f38fd28cea..500461fecf 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -750,7 +750,7 @@ and probably others.")
python-lxml
python-prompt-toolkit
python-requests
- python-pyqt-without-qtwebkit
+ python-pyqt
python-pyqtwebengine
python-pysocks
python-pyxdg
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index ec60df0bc0..a1c2294f7a 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -491,7 +491,7 @@ interface.")
;; FIXME: python-pyqtwebengine needs to come before python-pyqt so
;; that it's __init__.py is used first.
python-pyqtwebengine
- python-pyqt-without-qtwebkit
+ python-pyqt
;; While qtwebengine-5 is provided by python-pyqtwebengine, it's
;; included here so we can wrap QTWEBENGINEPROCESS_PATH.
qtwebengine-5))