summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2023-08-30 07:42:41 -0400
committerMark H Weaver <mhw@netris.org>2023-08-30 11:43:14 -0400
commitb74bdf490ed31fc8a652a1a51492f401a7f92209 (patch)
tree2c2e1dd0290c5f94460195fc96811e8e2ba6c9ec
parentebaff644a6ae87ca289c827d902b46e7877e66ec (diff)
gnu: icecat: Update to 102.15.0-guix0-preview1 [security fixes].
Includes fixes for CVE-2023-4573, CVE-2023-4574, CVE-2023-4575, CVE-2023-4576, CVE-2023-4581, and CVE-2023-4584. * gnu/packages/gnuzilla.scm (%icecat-base-version, %icecat-build-id): Update. (icecat-source): Update gnuzilla commit, base version, and hashes.
-rw-r--r--gnu/packages/gnuzilla.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index ee902da9a8..e190ac0a17 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -518,9 +518,9 @@ variable defined below. It requires guile-json to be installed."
;; XXXX: Workaround 'snippet' limitations.
(define computed-origin-method (@@ (guix packages) computed-origin-method))
-(define %icecat-base-version "102.14.0")
+(define %icecat-base-version "102.15.0")
(define %icecat-version (string-append %icecat-base-version "-guix0-preview1"))
-(define %icecat-build-id "20230801000000") ;must be of the form YYYYMMDDhhmmss
+(define %icecat-build-id "20230829000000") ;must be of the form YYYYMMDDhhmmss
;; 'icecat-source' is a "computed" origin that generates an IceCat tarball
;; from the corresponding upstream Firefox ESR tarball, using the 'makeicecat'
@@ -540,12 +540,12 @@ variable defined below. It requires guile-json to be installed."
"firefox-" upstream-firefox-version ".source.tar.xz"))
(sha256
(base32
- "1vpglmqm97ac3rs273qv7kldkrkawyhdnwwqhvyjqiwaq20m1f0s"))))
+ "1bs6hxfsb77cbi238wvizq2iw4mlgz29m0sd027sz8zm1025kyl1"))))
;; The upstream-icecat-base-version may be older than the
;; %icecat-base-version.
- (upstream-icecat-base-version "102.14.0")
- (gnuzilla-commit "ac19d793c76732f9e5623e25fbf31287255a4ae7")
+ (upstream-icecat-base-version "102.15.0")
+ (gnuzilla-commit "400fbfdbc0c1ac9c68c9f52fd2ab6899bc8e8bd0")
(gnuzilla-source
(origin
(method git-fetch)
@@ -557,7 +557,7 @@ variable defined below. It requires guile-json to be installed."
(string-take gnuzilla-commit 8)))
(sha256
(base32
- "0fghxy6d4102i4fsyj5x74v6q94kdfbszmirjbd63wlw1d8sy3cs"))))
+ "1fqrf94a5vnjq56zyyxlc1zsvbblgmzcks760nj1szpws4y91m8r"))))
;; 'search-patch' returns either a valid file name or #f, so wrap it
;; in 'assume-valid-file-name' to avoid 'local-file' warnings.