summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-22 13:19:38 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-22 13:19:38 +0300
commitc8a6281d12741374f89cace994250a830d8c9669 (patch)
tree06270cfb634560a305f2570cc51543a36cb5a186
parentf3fc593a7f1369ac9522e2e6ab07c5fca3fe1c13 (diff)
gnu: Add rust-option-set-0.2.
* gnu/packages/crates-io.scm (rust-option-set-0.2): New variable. (rust-option-set-0.1): Inherit from rust-option-set-0.2.
-rw-r--r--gnu/packages/crates-io.scm34
1 files changed, 28 insertions, 6 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e07d57b55c..616bb8e051 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -46445,8 +46445,35 @@ system for OpenSSL.")
(description "Extends `Option` with additional operations")
(license license:mpl2.0)))
+(define-public rust-option-set-0.2
+ (package
+ (name "rust-option-set")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "option-set" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0i6s3bmnrw44nffqbbcaiq7fyhz7j881lcgspb57jxsi752m11k0"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-heck" ,rust-heck-0.4)
+ ("rust-serde" ,rust-serde-1))
+ #:cargo-development-inputs
+ (("rust-bitflags" ,rust-bitflags-2)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-serde-yaml" ,rust-serde-yaml-0.9))))
+ (home-page "https://github.com/H2CO3/option_set.git")
+ (synopsis "Bitflags on steroids")
+ (description "This package provides an extended version of rust bitflags.")
+ (license license:expat)))
+
(define-public rust-option-set-0.1
(package
+ (inherit rust-option-set-0.2)
(name "rust-option-set")
(version "0.1.4")
(source (origin
@@ -46455,7 +46482,6 @@ system for OpenSSL.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "16wsxh2qmjb2bf7mcq7dhlpzwkslzgjpg3nwzx97ia6gpnb2sfy8"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-heck" ,rust-heck-0.3)
@@ -46464,11 +46490,7 @@ system for OpenSSL.")
(("rust-bitflags" ,rust-bitflags-1)
("rust-serde" ,rust-serde-1)
("rust-serde-json" ,rust-serde-json-1)
- ("rust-serde-yaml" ,rust-serde-yaml-0.8))))
- (home-page "https://github.com/H2CO3/option_set.git")
- (synopsis "Bitflags on steroids")
- (description "This package provides an extended version of rust bitflags.")
- (license license:expat)))
+ ("rust-serde-yaml" ,rust-serde-yaml-0.8))))))
(define-public rust-orbclient-0.3
(package