summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-13 07:52:30 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:40 +0200
commitc9347f438b14ad64554465dcc6c4541018771211 (patch)
tree285095c3da452973e18f0863ccba5ae318432980
parent40b0c09d2711dca951d272e51c21f4764e537211 (diff)
gnu: texlive-latex-stackengine -> texlive-stackengine.
* gnu/packages/tex.scm (texlive-stackengine): New variable. (texlive-latex-stackengine): Deprecate variable. * gnu/packages/maths.scm (hypre): Use new name.
-rw-r--r--gnu/packages/maths.scm2
-rw-r--r--gnu/packages/tex.scm26
2 files changed, 18 insertions, 10 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 4c9d379eab..1d42a7bbc7 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5811,7 +5811,7 @@ set.")
texlive-latex-needspace
texlive-newunicodechar
texlive-latex-parskip
- texlive-latex-stackengine
+ texlive-stackengine
texlive-latex-tabulary
texlive-latex-tocloft
texlive-latex-upquote
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a371eb7151..8cc1020e1a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5616,16 +5616,22 @@ user may consider the @code{dnaseq} as a rather more powerful alternative.")
result in the same document.")
(license license:lppl1.2+)))
-(define-public texlive-latex-stackengine
+(define-public texlive-stackengine
(package
- (inherit (simple-texlive-package
- "texlive-latex-stackengine"
- (list "/doc/latex/stackengine/"
- "/tex/latex/stackengine/")
- (base32
- "1rbw3dmb6kl3wlnpxacr8cmp2ivac1kpnb33k7r5s3lp1q59ck38")
- #:trivial? #t))
- (home-page "https://www.ctan.org/pkg/stackengine")
+ (name "texlive-stackengine")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/stackengine/"
+ "tex/latex/stackengine/")
+ (base32
+ "1rbw3dmb6kl3wlnpxacr8cmp2ivac1kpnb33k7r5s3lp1q59ck38")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-etoolbox
+ texlive-listofitems))
+ (home-page "https://ctan.org/pkg/stackengine")
(synopsis "Customised stacking of objects")
(description
"The package provides a versatile way to stack objects vertically in a
@@ -5633,6 +5639,8 @@ variety of customizable ways. A number of useful macros are provided, all
of which make use of the @code{stackengine} core.")
(license license:lppl1.3+)))
+(define-deprecated-package texlive-latex-stackengine texlive-stackengine)
+
(define-public texlive-latex-tocloft
(package
(inherit (simple-texlive-package