summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundationdevices.com>2023-07-28 14:23:57 +0200
committerVagrant Cascadian <vagrant@debian.org>2023-08-29 17:12:43 -0700
commitd98bc6094120fa26d0de6af5cc16bc7644076f7c (patch)
tree9d89bc67266d936390d4bc5e67e2ac87b8694ef2
parent2da454d2033d95f108c26ac0018cf73b18823d43 (diff)
gnu: Add python-spinners.
* gnu/packages/terminals.scm (python-spinners): New variable. Signed-off-by: Jean-Pierre De Jesus DIAZ <jean@foundationdevices.com> Signed-off-by: Vagrant Cascadian <vagrant@debian.org>
-rw-r--r--gnu/packages/terminals.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index c59b1a6588..c5bf4ed69b 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -34,6 +34,7 @@
;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2023 Aaron Covrig <aaron.covrig.us@ieee.org>
+;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -100,6 +101,7 @@
#:use-module (gnu packages popt)
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-check)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
@@ -1158,6 +1160,32 @@ terminal. It features string-like objects which carry formatting information,
per-line fullscreen terminal rendering, and keyboard input event reporting.")
(license license:expat)))
+(define-public python-spinners
+ (package
+ (name "python-spinners")
+ (version "0.0.24")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "spinners" version))
+ (sha256
+ (base32
+ "0zz2z6dpdjdq5z8m8w8dfi8by0ih1zrdq0caxm1anwhxg2saxdhy"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "requirements-dev.txt"
+ (("(.*)==(.*)$" _ dep ver)
+ (string-append dep ">=" ver))))))))
+ (native-inputs (list python-coverage python-nose python-pylint python-tox))
+ (home-page "https://github.com/manrajgrover/py-spinners")
+ (synopsis "Python library with graphical spinners for the terminal")
+ (description "Spinners is a Python library that contains graphical spinners
+that can be displayed terminal.")
+ (license license:expat)))
+
(define-public tmate
(package
(name "tmate")