summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2023-08-17 23:46:20 +0100
committerArun Isaac <arunisaac@systemreboot.net>2023-10-05 17:38:32 +0100
commitdb52c06c3d6478c3e79d79f98ce7d9c229b1eb64 (patch)
tree35ff44b5f83617ab5553700a67f7237aee2ce4f8
parentfaad060771bfb0d210b4dbb14e79f18bdf627292 (diff)
gnu: cgit: Fix cross compilation.
* gnu/packages/version-control.scm (cgit)[native-inputs]: Move bzip2, gzip and xz to ... [inputs]: ... here. Add bash-minimal. [arguments]: Use cc-for-target.
-rw-r--r--gnu/packages/version-control.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 53c476d607..f504fe9831 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1043,7 +1043,8 @@ collaboration using typical untrusted file hosts or services.")
(list
#:tests? #f ; XXX: fail to build the in-source git.
#:test-target "test"
- #:make-flags '("CC=gcc" "SHELL_PATH=sh")
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ "SHELL_PATH=sh")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'unpack-git
@@ -1103,7 +1104,7 @@ collaboration using typical untrusted file hosts or services.")
"html-converters/md2html")))))))
(native-inputs
;; For building manpage.
- (list asciidoc gzip bzip2 xz))
+ (list asciidoc))
(inputs
`(;; Building cgit requires a Git source tree.
("git-source"
@@ -1114,13 +1115,20 @@ collaboration using typical untrusted file hosts or services.")
(uri "mirror://kernel.org/software/scm/git/git-2.25.4.tar.xz")
(sha256
(base32 "11am6s46wmn1yll5614smjhzlghbqq6gysgcs64igjr9y5wzpdxq"))))
+ ("bash-minimal" ,bash-minimal)
("openssl" ,openssl)
- ("groff" ,groff)
("python" ,python)
("python-docutils" ,python-docutils)
("python-markdown" ,python-markdown)
("python-pygments" ,python-pygments)
- ("zlib" ,zlib)))
+ ("zlib" ,zlib)
+ ;; bzip2, groff, gzip and xz are inputs (not native inputs)
+ ;; since they are actually substituted into cgit source and
+ ;; referenced by the built package output.
+ ("bzip2" ,bzip2)
+ ("groff" ,groff)
+ ("gzip" ,gzip)
+ ("xz" ,xz)))
(home-page "https://git.zx2c4.com/cgit/")
(synopsis "Web frontend for git repositories")
(description