summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-12-13 22:56:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-04-21 13:43:54 +0200
commitfd4db8c13d7a1ac2bfef604aab6069760faeb2fb (patch)
treee38146d61863f7900e5e111f3b1d6ebbd8c48f75
parenteb4d9b2dffdb9977c3cf280c73e8dd3f98b11acf (diff)
gnu: python-pytest-xdist: Use pyproject-build-system.
* gnu/packages/check.scm (python-pytest-xdist): Use pyproject-build-system.
-rw-r--r--gnu/packages/check.scm10
1 files changed, 1 insertions, 9 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index fc13f544a1..1e7ff1a317 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1741,15 +1741,7 @@ same arguments.")
(sha256
(base32
"1psf5dqxvc38qzxvc305mkg5xpdmdkbkkfiyqlmdnkgh7z5dx025"))))
- (build-system python-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv"
- "-n" (number->string (parallel-job-count)))))))))
+ (build-system pyproject-build-system)
(native-inputs (list python-setuptools-scm python-filelock python-pytest))
(propagated-inputs (list python-execnet python-pytest-forked))
(home-page "https://github.com/pytest-dev/pytest-xdist")