summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-03-10 21:40:56 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-03-19 21:14:38 +0200
commit0b483d32f798fd29208ac3aeec26466d1a7f5b45 (patch)
treebe24e308d654f9fc827c7b69f5bbea575e5ca992
parent6f0e1435a2c85f43dd0806fafb13116412eb89db (diff)
gnu: Add perl6-test-mock.
* gnu/packages/perl6.scm (perl6-test-mock): New variable.
-rw-r--r--gnu/packages/perl6.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index 8c6c27a42d..cf8a400e8e 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -579,6 +579,33 @@ minimal wrapper around an instance of this module.")
some confidence that they have a working distribution META description file.")
(license license:artistic2.0)))
+(define-public perl6-test-mock
+ (package
+ (name "perl6-test-mock")
+ (version "1.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jnthn/test-mock")
+ ;; The commit where 1.5 was "tagged"
+ (commit "6eddb42f73f40b9ac29c14badb41ce4a04d876f2")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07yr3qimc8fl29p23562ayj2j9h53madcnf9sgqvgf2kcprh0zd2"))))
+ (build-system rakudo-build-system)
+ (propagated-inputs
+ `(("perl6-oo-monitors" ,perl6-oo-monitors)))
+ (home-page "https://github.com/jnthn/test-mock")
+ (synopsis "Module for simply generating and checking mock objects")
+ (description "@code{Test::Mock} is a module that works alongside the
+standard Test module to help you write tests when you want to verify what
+methods are called on an object, while still having calls to undefined methods
+die. You get started just as normal with the test file, but also add a use
+statement for @code{Test::Mock}.")
+ (license license:artistic2.0)))
+
(define-public perl6-uri
(package
(name "perl6-uri")