summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-02-28 09:11:53 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-03-19 21:14:35 +0200
commit17eecb2ccb25e525b006d1d203a6400543a233ca (patch)
tree9d7f7f189258eb90d1ff52ce7329775135f8832a
parent8ba4797a6ddae815dff390edffa1812f1174a1d4 (diff)
gnu: Add perl6-uri.
* gnu/packages/perl6.scm (perl6-uri): New variable.
-rw-r--r--gnu/packages/perl6.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index aea2809066..c65ba8361b 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -258,6 +258,30 @@ TAP based test suite and prints a report. The @command{prove6} command is a
minimal wrapper around an instance of this module.")
(license license:artistic2.0)))
+(define-public perl6-uri
+ (package
+ (name "perl6-uri")
+ (version "0.1.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/perl6-community-modules/uri.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0h318g75jqn2ckw051g35iqyfxz1mps0jyg5z6pd857y3kacbkpl"))))
+ (build-system rakudo-build-system)
+ (arguments '(#:with-zef? #f))
+ (home-page "https://github.com/perl6-community-modules/uri")
+ (synopsis "URI implementation using Perl 6")
+ (description "A URI implementation using Perl 6 grammars to implement RFC
+3986 BNF. Currently only implements parsing. Includes @code{URI::Escape} to
+(un?)escape characters that aren't otherwise allowed in a URI with % and a hex
+character numbering.")
+ (license license:artistic2.0)))
+
(define-public perl6-zef
(package
(name "perl6-zef")