summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-03-10 21:13:49 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-03-19 21:14:37 +0200
commit5f6f1f3d2532cfcf63111a0a733f411eeb7d9e3a (patch)
tree751819533969c7756796af9c11260798ba194aa8
parentc256393fb75d967f768d09642a8a95e2cde44f1d (diff)
gnu: Add perl6-svg.
* gnu/packages/perl6.scm (perl6-svg): New variable.
-rw-r--r--gnu/packages/perl6.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index 840f5a9c8b..0db41da0c0 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -422,6 +422,34 @@ as per the spec and where known the places that @quot{customary} attributes are
used.")
(license license:artistic2.0)))
+(define-public perl6-svg
+ ;; Latest commit, basically unchanged since August 2015
+ (let ((commit "07190c0602aa276e5319f06aa0012452dbff3582")
+ (revision "1"))
+ (package
+ (name "perl6-svg")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/moritz/svg")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0mkjdhg7ajksdn61n8fqhyzfd7ly9myazsvpsm02a5c2q73hdygg"))))
+ (build-system rakudo-build-system)
+ (propagated-inputs
+ `(("perl6-xml-writer" ,perl6-xml-writer)))
+ (home-page "https://github.com/moritz/svg")
+ (synopsis "Perl 6 module to generate SVG")
+ (description "This is a Perl 6 module that makes it easy to write
+@dfn{Scalable Vector Graphic files} (SVG). Right now it is a shallow wrapper
+around @code{XML::Writer}, adding only the xmlns attributes that identifies an
+XML file as SVG.")
+ (license license:artistic2.0))))
+
(define-public perl6-tap-harness
(package
(name "perl6-tap-harness")