summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-02-28 10:01:38 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-03-19 21:14:35 +0200
commit8657ba2ffd3a8357a13c207096a0184ca15fa152 (patch)
tree19b830de116d480916c74aaef806a9e6e545105b
parent17eecb2ccb25e525b006d1d203a6400543a233ca (diff)
gnu: Add perl6-json-fast.
* gnu/packages/perl6.scm (perl6-json-fast): New variable.
-rw-r--r--gnu/packages/perl6.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index c65ba8361b..fc09651541 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -228,6 +228,30 @@ regular expression engine for the virtual machine.")
specification and runs on top of several virtual machines.")
(license license:artistic2.0)))
+(define-public perl6-json-fast
+ (package
+ (name "perl6-json-fast")
+ (version "0.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/timo/json_fast.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1fif081gdxdnja14vkj523p9dyzdcdj81lmjv9fvfazvpagb6dg2"))))
+ (build-system rakudo-build-system)
+ (arguments '(#:with-zef? #f))
+ (home-page "https://github.com/timo/json_fast")
+ (synopsis "Perl6 json parser")
+ (description "A naive imperative json parser in pure perl6 (but with direct
+access to @code{nqp::} ops), to evaluate performance against @code{JSON::Tiny}.
+It is a drop-in replacement for @code{JSON::Tiny}'s from-json and to-json subs,
+but it offers a few extra features.")
+ (license license:artistic2.0)))
+
(define-public perl6-tap-harness
(package
(name "perl6-tap-harness")