summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-02-26 14:51:53 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-03-19 21:14:34 +0200
commit8ba4797a6ddae815dff390edffa1812f1174a1d4 (patch)
tree5ad5e95a98bf7b6b34a3bcbe655a0108e3b9eea3
parentacbc419c853961d18d44ecb11559afef3a439521 (diff)
gnu: Add perl6-zef.
* gnu/packages/perl6.scm (perl6-zef): New variable.
-rw-r--r--gnu/packages/perl6.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index 8a1810612f..aea2809066 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -257,3 +257,34 @@ specification and runs on top of several virtual machines.")
TAP based test suite and prints a report. The @command{prove6} command is a
minimal wrapper around an instance of this module.")
(license license:artistic2.0)))
+
+(define-public perl6-zef
+ (package
+ (name "perl6-zef")
+ (version "0.6.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ugexe/zef.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07n7g1xw2c4g860rs890gx85vyhdq0ysgwbrnzw6q905jph2bkv7"))))
+ (build-system rakudo-build-system)
+ (arguments
+ '(#:with-zef? #f
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (setenv "HOME" "/tmp")
+ (invoke "perl6" "-I." "bin/zef" "--debug"
+ "--tap-harness" "test" "."))))))
+ (home-page "https://github.com/ugexe/zef")
+ (synopsis "Perl6 Module Management")
+ (description "Zef is a Perl 6 package (module) manager. It can be used to
+download and install Perl 6 modules in your home directory or as a system-wide
+module.")
+ (license license:artistic2.0)))