summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-03-10 21:25:00 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-03-19 21:14:37 +0200
commit8e0fbd1e0a4adc5dfe851f7a70cfb8966ba2cc75 (patch)
tree35f1ae1a1a20702cdbd78ea5cd5d4f829fb093e6
parent308faa1174c4d2f581b1a155bc65d6decaef2502 (diff)
gnu: Add perl6-terminal-ansicolor.
* gnu/packages/perl6.scm (perl6-terminal-ansicolor): New variable.
-rw-r--r--gnu/packages/perl6.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index 393b533636..fb594c790f 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -507,6 +507,28 @@ TAP based test suite and prints a report. The @command{prove6} command is a
minimal wrapper around an instance of this module.")
(license license:artistic2.0)))
+(define-public perl6-terminal-ansicolor
+ (package
+ (name "perl6-terminal-ansicolor")
+ (version "0.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tadzik/Terminal-ANSIColor.git")
+ ;; The commit where 0.5 was "tagged"
+ (commit "edded4a7116ce11cbc9fb5a83669c7ba119d0212")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1apm999azkyg5s35gid12wq019aqnvzrkz7qjmipd74mdxgr00x7"))))
+ (build-system rakudo-build-system)
+ (arguments '(#:with-zef? #f))
+ (home-page "https://github.com/tadzik/Terminal-ANSIColor")
+ (synopsis "Colorize terminal output")
+ (description "This is a @code{Terminal::ANSIColor} module for Perl 6.")
+ (license license:expat)))
+
(define-public perl6-test-meta
(package
(name "perl6-test-meta")