summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-03-18 13:02:57 -0400
committerLeo Famulari <leo@famulari.name>2019-03-18 16:10:48 -0400
commitbf197dcda060376e8af5b6c2886c9df023194548 (patch)
tree5766a3a3e2aaf025b91ed939e4e3413f7de8a347
parent18199da4b79ce79d5002c3290cc1fa95454d92ce (diff)
gnu: Go 1.11: Update to 1.11.6.
* gnu/packages/golang.scm (go-1.11): Update to 1.11.6. [arguments]: Remove the 'tarbomb-workaround' phase and inherit the 'chdir' phase.
-rw-r--r--gnu/packages/golang.scm16
1 files changed, 2 insertions, 14 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index dd9f55352a..cc896405cb 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -226,7 +226,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(package
(inherit go-1.4)
(name "go")
- (version "1.11.5")
+ (version "1.11.6")
(source
(origin
(method url-fetch)
@@ -234,23 +234,11 @@ in the style of communicating sequential processes (@dfn{CSP}).")
name version ".src.tar.gz"))
(sha256
(base32
- "0gllmbjvp12iszwils8id78mvjxwviwf98lh2gdkb236n4mz07mw"))))
+ "0cz1sdhxf9283p1p4jxb020pym0ncd0qlfh36r3hkv6bbm1a2vd9"))))
(arguments
(substitute-keyword-arguments (package-arguments go-1.4)
((#:phases phases)
`(modify-phases ,phases
- ;; XXX Work around the Go 1.11.5 tarbomb.
- ;; <https://github.com/golang/go/issues/29906>
- (add-after 'unpack 'tarbomb-workaround
- (lambda _
- (chdir "..")
- (delete-file-recursively "gocache")
- (delete-file-recursively "tmp")
- #t))
- (replace 'chdir
- (lambda _
- (chdir "go/src")
- #t))
(replace 'prebuild
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((gcclib (string-append (assoc-ref inputs "gcc:lib") "/lib"))