summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-19 12:15:46 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-03-19 12:22:18 +0100
commitcf31179062c99bc0ea4e2dab43d734036f117295 (patch)
treea4b52389ba7c58d351bfb716db6755924b9b5094
parent3e0df6cd4ad7b4eba6564976c98a94d131d44494 (diff)
gnu: hyperledger-fabric: Use git tag.
* gnu/packages/hyperledger.scm (hyperledger-fabric)[source]: Check out the (supposedly immutable) tag instead of the (maintenance) branch.
-rw-r--r--gnu/packages/hyperledger.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/hyperledger.scm b/gnu/packages/hyperledger.scm
index b25a3c48e7..158a66e898 100644
--- a/gnu/packages/hyperledger.scm
+++ b/gnu/packages/hyperledger.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -34,7 +35,7 @@
(define-public hyperledger-fabric
(package
(name "hyperledger-fabric")
- (version "1.4")
+ (version "1.4.0")
;; While the GitHub repository is supposed to be "just a mirror," the Go
;; imports refer to it explicitly.
(home-page "https://github.com/hyperledger/fabric")
@@ -42,10 +43,11 @@
(method git-fetch)
(uri (git-reference
(url home-page)
- (commit (string-append "release-" version))))
+ ;; ‘release-…’ are branches, and move. ‘v…’ are the tags.
+ (commit (string-append "v" version))))
(sha256
(base32
- "1g003wf6439f2c9i2vphf4sh463yyasq1vpqmkpw9lj170a6kl8k"))
+ "0nmg24ishwddxm1i2vh5ah5ylmmcg0apnjbgv1hljvhl48k4pzxq"))
(file-name (git-file-name name version))))
(build-system go-build-system)
(native-inputs