summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-02-28 11:48:41 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-03-19 21:14:35 +0200
commitde084a3afc3aea30fb17770bf4b670bfc1a29d34 (patch)
treee8266e22c5898da585e16ec8a418f42f3228b577
parentfc292ef18f7ae86e41496e6778bc12645fcb4f09 (diff)
gnu: Add perl6-json-marshal.
* gnu/packages/perl6.scm (perl6-json-marshal): New variable.
-rw-r--r--gnu/packages/perl6.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index d2f682096c..83f4a35cd6 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -252,6 +252,33 @@ It is a drop-in replacement for @code{JSON::Tiny}'s from-json and to-json subs,
but it offers a few extra features.")
(license license:artistic2.0)))
+(define-public perl6-json-marshal
+ (package
+ (name "perl6-json-marshal")
+ (version "0.0.16")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jonathanstowe/JSON-Marshal.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qy7j83h6gjzyyv74ncd92cd9h45rv8diaz3vldiv3b6fqwz4c6i"))))
+ (build-system rakudo-build-system)
+ (propagated-inputs
+ `(("perl6-json-fast" ,perl6-json-fast)
+ ("perl6-json-name" ,perl6-json-name)))
+ (native-inputs
+ `(("perl6-json-fast" ,perl6-json-fast)))
+ (home-page "https://github.com/jonathanstowe/JSON-Marshal")
+ (synopsis "Simple serialisation of objects to JSON")
+ (description "This library provides a single exported subroutine to create
+a JSON representation of an object. It should round trip back into an object
+of the same class using @code{JSON::Unmarshal}.")
+ (license license:artistic2.0)))
+
(define-public perl6-json-name
(package
(name "perl6-json-name")