summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-03-10 09:11:23 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-03-19 21:14:36 +0200
commitf280ba9ab0bd1a4e1641d445adeec34796d26446 (patch)
tree5b3377b38063c9570a02096c2629638f295d4dd0
parent4b12e1471bdd8349f235a3d4c5aaee7b6ccde6f6 (diff)
gnu: Add perl6-test-meta.
* gnu/packages/perl6.scm (perl6-test-meta): New variable.
-rw-r--r--gnu/packages/perl6.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index 403727c3f6..c1c1247540 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -452,6 +452,30 @@ TAP based test suite and prints a report. The @command{prove6} command is a
minimal wrapper around an instance of this module.")
(license license:artistic2.0)))
+(define-public perl6-test-meta
+ (package
+ (name "perl6-test-meta")
+ (version "0.0.14")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jonathanstowe/Test-META")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1mzrglb7lbiy5h9dlc7dyhvv9gppxmdmpmrv6nzbd695jzr38bri"))))
+ (build-system rakudo-build-system)
+ (propagated-inputs
+ `(("perl6-meta6" ,perl6-meta6)
+ ("perl6-uri" ,perl6-uri)))
+ (home-page "https://github.com/jonathanstowe/Test-META")
+ (synopsis "Test a distributions META file")
+ (description "This provides a simple mechanism for module authors to have
+some confidence that they have a working distribution META description file.")
+ (license license:artistic2.0)))
+
(define-public perl6-uri
(package
(name "perl6-uri")