summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-19 16:22:14 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-03-19 16:57:47 +0100
commitfc82c1752e5694daf498d351610235bfab7e890c (patch)
tree88eae13c676087a6d9da0c0aeffb59fe8562be71
parent7f5a010b9a9363fb24fe9f0cb1e2470f5b96db1c (diff)
gnu: google-brotli: Don't use unstable tarball.
* gnu/packages/compression.scm (google-brotli)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/compression.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index e3c23126b0..2f32fb05ed 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1759,13 +1759,15 @@ non-Windows systems without running the actual installer using wine.")
(package
(name "google-brotli")
(version "1.0.4")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/google/brotli/archive/v"
- version ".tar.gz"))
- (sha256
- (base32
- "1hrpmz162k4x3xm6vmbpm443jlfr1kp536p8962y2dncy7gs6s12"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/brotli.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0n5snycxgwqj2v8sgxiqxq4zqh5ydx70dr7qa4ygizs02ms69n1i"))))
(build-system cmake-build-system)
(arguments
`(#:phases