summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorla snesne <lasnesne@lagunposprasihopre.org>2021-04-01 01:12:15 +0900
committerLudovic Courtès <ludo@gnu.org>2021-04-10 22:59:52 +0200
commit96026bdb8fc3ebcdb4b4144246a1ae8105eefb7c (patch)
treeec8054127bdf3148617305ce1d083d01e8037b98
parentcb41c15827a2e910aa56fb5d1917ba8a085c95c7 (diff)
gnu: Add wlogout.
* gnu/packages/wm.scm (wlogout): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/wm.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 4df1af27cb..90896c2b89 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -44,6 +44,7 @@
;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 qblade <qblade@protonmail.com>
+;;; Copyright © 2021 lasnesne <lasnesne@lagunposprasihopre.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2451,3 +2452,39 @@ read and write, and compatible with JSON.")
"Hikari is a stacking Wayland compositor with additional tiling
capabilities. It is heavily inspired by the Calm Window manager(cwm).")
(license license:bsd-2)))
+
+(define-public wlogout
+ (package
+ (name "wlogout")
+ (version "1.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ArtsyMacaw/wlogout")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1swhzkqkzli59c89pvrakfvicd00x7ga860c3x2pbb4y3xziqfvi"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("scdoc" ,scdoc)))
+ (inputs
+ `(("gtk-layer-shell" ,gtk-layer-shell)
+ ("gtk+" ,gtk+)))
+ (arguments
+ '(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-source-paths
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "main.c"
+ (("/usr/share") (string-append out "/share"))
+ (("/etc") (string-append out "/etc"))))
+ #t)))))
+ (home-page "https://github.com/ArtsyMacaw/wlogout")
+ (synopsis "Logout menu for Wayland")
+ (description "wlogout is a logout menu for Wayland environments.")
+ (license license:expat)))