summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundation.xyz>2024-07-03 18:36:41 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-03 22:29:58 +0100
commit2dd43fdacc1334f7ff3f42ac00d8dbf1f13cc79d (patch)
treefb494ef9153c4f0840072d89d02499cbd2e7974b
parent13ae21cd05bc69595bea97cd9c63c5f135e4427f (diff)
gnu: podman: Fix build.
* gnu/packages/containers.scm (podman)<arguments>: Remove 'remove-go-references phase, add BUILDFLAGS=-trimpath to make-flags and remove imported modules. Change-Id: I6ffca5bd5be21b8b61ea9aa50273f97c5e342f9d Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/containers.scm17
1 files changed, 2 insertions, 15 deletions
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index 8cded06753..241858af94 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -474,12 +474,10 @@ Its main purpose is to support the key usage by @code{docker-init}:
(string-append "PREFIX=" #$output)
(string-append "HELPER_BINARIES_DIR=" #$output "/_guix")
(string-append "GOMD2MAN="
- #$go-github-com-go-md2man "/bin/go-md2man"))
+ #$go-github-com-go-md2man "/bin/go-md2man")
+ (string-append "BUILDFLAGS=-trimpath"))
#:tests? #f ; /sys/fs/cgroup not set up in guix sandbox
#:test-target "test"
- #:imported-modules
- (source-module-closure `(,@%gnu-build-system-modules
- (guix build go-build-system)))
#:phases
#~(modify-phases %standard-phases
(delete 'configure)
@@ -531,17 +529,6 @@ Its main purpose is to support the key usage by @code{docker-init}:
,(string-append #$passt "/bin")
,(string-append #$procps "/bin") ; ps
"/run/setuid-programs")))))
- (add-after 'install 'remove-go-references
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((go (assoc-ref inputs "go")))
- (for-each
- (lambda (file)
- (when (executable-file? file)
- ((@@ (guix build go-build-system) remove-store-reference)
- file go)))
- (append (find-files (string-append #$output "/bin"))
- (find-files (string-append #$output "/libexec"))
- (find-files (string-append #$output "/lib")))))))
(add-after 'install 'install-completions
(lambda _
(invoke "make" "install.completions"