summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-24 21:24:47 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-03 22:23:23 +0100
commit44ec3b17df78b62b07a55ee136ca9f6eb506ad08 (patch)
tree620bf267b3024cb30da5d4b643273b9ad610fa8d
parent863197b9e687cb889d9a03101b509f8d782ec21c (diff)
gnu: Add go-atomicgo-dev-schedule.
* gnu/packages/golang-xyz.scm (go-atomicgo-dev-schedule): New variable. Change-Id: Iee83258d43320bbd99170c9bcb21f7d6984366bc
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 4bdcc05c47..f836449d54 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -111,6 +111,31 @@ and games, live charts, algorithm visualizations and other updatable output of
any kind.")
(license license:expat)))
+(define-public go-atomicgo-dev-schedule
+ (package
+ (name "go-atomicgo-dev-schedule")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/atomicgo/schedule")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13zrmf9jagqjvjjckyqlvr889y2gxf22iz42l6j2zmgy9klbn6vl"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.18
+ #:import-path "atomicgo.dev/schedule"))
+ (home-page "https://atomicgo.dev/schedule")
+ (synopsis "Easily schedule non-blocking tasks in Golang")
+ (description
+ "This package provides a simple scheduler which, can run a function at a
+given time, in a given duration, or repeatedly at a given interval.")
+ (license license:expat)))
+
(define-public go-bazil-org-fuse
(package
(name "go-bazil-org-fuse")