summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2024-06-18 21:10:30 -0400
committerLeo Famulari <leo@famulari.name>2024-07-03 21:47:19 -0400
commit6c6670d9096291798ffe77268fa4f7e07d83a01f (patch)
tree21ebaabee274151d43bcdad446591edd95e18ec0
parent190ca32d243fc8a0341cb8d90ae2485a6e646bb3 (diff)
gnu: Add python-urllib3 1.26.17.
This is the minimum required version in recent versions of yt-dlp. * gnu/packages/python-web.scm (python-urllib3-next): New variable. Change-Id: Ib57bbe45fd1c9c9fa3872a00f161979762feacf6
-rw-r--r--gnu/packages/python-web.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 2686cb283f..98aa46dafc 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4024,6 +4024,41 @@ can reuse the same socket connection for multiple requests, it can POST files,
supports url redirection and retries, and also gzip and deflate decoding.")
(license license:expat)))
+(define-public python-urllib3-next
+ (package
+ (name "python-urllib3")
+ (version "1.26.17")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "urllib3" version))
+ (sha256
+ (base32
+ "08fzhaf77kbjj5abpl9xag6fpfxkdp1k5s7sqd3ayacdq91a5mi4"))))
+ (build-system python-build-system)
+ (arguments `(#:tests? #f))
+ (propagated-inputs
+ (append
+ ;; These 5 inputs are used to build urrlib3[secure]
+ (list python-certifi)
+ (if (member (%current-system)
+ (package-transitive-supported-systems python-cryptography))
+ (list python-cryptography)
+ '())
+ (list python-idna)
+ (if (member (%current-system)
+ (package-transitive-supported-systems python-pyopenssl))
+ (list python-pyopenssl)
+ '())
+ (list python-pysocks)))
+ (home-page "https://urllib3.readthedocs.io/")
+ (synopsis "HTTP library with thread-safe connection pooling")
+ (description
+ "Urllib3 supports features left out of urllib and urllib2 libraries. It
+can reuse the same socket connection for multiple requests, it can POST files,
+supports url redirection and retries, and also gzip and deflate decoding.")
+ (license license:expat)))
+
(define-public awscli
(package
;; Note: updating awscli typically requires updating botocore as well.