summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-29 20:40:32 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-03 22:23:21 +0100
commit8c8fb5c878b0efc02dc92e31e90d40fc4d850937 (patch)
treefbc17d6ed9cdf072894934d78782197942a70aa3
parentbcad85a80e833471c2b6453ea86b33535aee0853 (diff)
gnu: Add go-github-com-adrg-strutil.
* gnu/packages/golang-xyz.scm (go-github-com-adrg-strutil): New variable. Change-Id: I86addc399471f4766a3beb7725832b6b13435fce
-rw-r--r--gnu/packages/golang-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index dafa4b2904..ae3eda6936 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -290,6 +290,32 @@ Golang.")
substitution.")
(license license:expat)))
+(define-public go-github-com-adrg-strutil
+ (package
+ (name "go-github-com-adrg-strutil")
+ (version "0.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/adrg/strutil")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0xkjzjllv8b2m3lgn66cb09b0f5xqy2bk8ny3lkn4z0ywlchawj9"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/adrg/strutil"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/adrg/strutil")
+ (synopsis "Golang string utility functions")
+ (description
+ "Package strutil provides string metrics for calculating string
+similarity as well as other string utility functions.")
+ (license license:expat)))
+
(define-public go-github-com-alecthomas-chroma
(package
(name "go-github-com-alecthomas-chroma")