summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-09-01 22:53:06 +0800
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-05 19:50:44 -0400
commit2ae57c98a9e50105fc2f967b5350c63ff8f22dbd (patch)
treeb4d0299af7607db3ee451a1246d0adb299ed01b5
parent35c254e5fdf3f0c15f667bbb3f312db99bf0c2dd (diff)
gnu: simh: Use G-Expressions.
* gnu/packages/simh.scm (simh)[arguments]: Convert to list of G-Expressions. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/simh.scm70
1 files changed, 35 insertions, 35 deletions
diff --git a/gnu/packages/simh.scm b/gnu/packages/simh.scm
index 2cf92516ba..9f5c04d8fb 100644
--- a/gnu/packages/simh.scm
+++ b/gnu/packages/simh.scm
@@ -19,6 +19,7 @@
(define-module (gnu packages simh)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -48,41 +49,40 @@
(inputs
(list libpcap))
(arguments
- `(#:tests? #f
- #:make-flags (list
- (string-append "GCC=" ,(cc-for-target) " -fcommon"))
- #:modules ((ice-9 string-fun)
- ,@%gnu-build-system-modules)
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (add-before 'build 'prepare-build
- (lambda _
- (substitute* "makefile"
- (("LIBPATH:=/usr/lib")
- (string-append "LIBPATH:="
- (string-replace-substring
- (getenv "LIBRARY_PATH") ":" " ")))
- (("export LIBRARY_PATH = .*") ""))
- (mkdir "BIN")))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin/"))
- (lib (string-append out "/lib/simh/")))
- (mkdir-p bin)
- (mkdir-p lib)
- (for-each
- (lambda (file)
- (copy-file file (string-append bin
- "simh-"
- (basename file))))
- (find-files "BIN"))
- (for-each
- (lambda (file)
- (copy-file file (string-append lib
- (basename file))))
- (find-files "VAX" "bin$"))))))))
+ (list #:tests? #f
+ #:make-flags
+ #~(list (string-append "GCC=" #$(cc-for-target) " -fcommon"))
+ #:modules `((ice-9 string-fun)
+ ,@%gnu-build-system-modules)
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'prepare-build
+ (lambda _
+ (substitute* "makefile"
+ (("LIBPATH:=/usr/lib")
+ (string-append "LIBPATH:="
+ (string-replace-substring
+ (getenv "LIBRARY_PATH") ":" " ")))
+ (("export LIBRARY_PATH = .*") ""))
+ (mkdir "BIN")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin/"))
+ (lib (string-append out "/lib/simh/")))
+ (mkdir-p bin)
+ (mkdir-p lib)
+ (for-each (lambda (file)
+ (copy-file file
+ (string-append bin "simh-"
+ (basename file))))
+ (find-files "BIN"))
+ (for-each (lambda (file)
+ (copy-file file
+ (string-append lib
+ (basename file))))
+ (find-files "VAX" "bin$"))))))))
(home-page "http://simh.trailing-edge.com")
(synopsis "Collection of simulators from The Computer History Simulation
Project")