summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-09-01 22:51:02 +0800
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-05 19:50:44 -0400
commit35c254e5fdf3f0c15f667bbb3f312db99bf0c2dd (patch)
treeb81a45aae9cdccaeba6712f455fe2a2270588d49
parent93eba03191e7efcc7017b6fbe55ba83266972df7 (diff)
gnu: simh: Update to 3.12-4.
* gnu/packages/simh.scm (simh): Update to 3.12-4. [source]: Switch to url-fetch. [native-inputs]: Add unzip. [arguments]: Adjust make-flags. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/simh.scm40
1 files changed, 24 insertions, 16 deletions
diff --git a/gnu/packages/simh.scm b/gnu/packages/simh.scm
index 81d26bbde0..2cf92516ba 100644
--- a/gnu/packages/simh.scm
+++ b/gnu/packages/simh.scm
@@ -23,39 +23,47 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
- #:use-module (gnu packages admin))
+ #:use-module (guix utils)
+ #:use-module (gnu packages admin)
+ #:use-module (gnu packages compression))
(define-public simh
(package
(name "simh")
- (version "3.9-0")
+ (version "3.12-4")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/simh/simh")
- (commit (string-append "v" version))))
+ (method url-fetch)
+ (uri (list (string-append
+ "http://simh.trailing-edge.com/sources/simhv"
+ (string-delete #\. version) ".zip")
+ (string-append
+ "http://simh.trailing-edge.com/sources/archive/simhv"
+ (string-delete #\. version) ".zip")))
(sha256
- (base32 "1jiq6shj6a9xvzacvmyhxxd6xdyica8q4006qqjh5mh96rxrp15c"))
- (file-name (git-file-name name version))))
+ (base32 "1i78c1x8xjiwy9dd2ss0mk3f1v9pmcjb4zc37ikqnjarsfqj2nm0"))))
(build-system gnu-build-system)
+ (native-inputs
+ (list unzip))
(inputs
(list libpcap))
(arguments
- '(#:tests? #f
+ `(#:tests? #f
#:make-flags (list
- "LDFLAGS=-lm"
- (string-append "INCPATH="
- (assoc-ref %build-inputs "libpcap")
- "/include")
- (string-append "LIBPATH="
- (assoc-ref %build-inputs "libpcap")
- "/lib"))
+ (string-append "GCC=" ,(cc-for-target) " -fcommon"))
+ #:modules ((ice-9 string-fun)
+ ,@%gnu-build-system-modules)
#:phases
(modify-phases %standard-phases
(delete 'configure)
(add-before 'build 'prepare-build
(lambda _
+ (substitute* "makefile"
+ (("LIBPATH:=/usr/lib")
+ (string-append "LIBPATH:="
+ (string-replace-substring
+ (getenv "LIBRARY_PATH") ":" " ")))
+ (("export LIBRARY_PATH = .*") ""))
(mkdir "BIN")))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)