summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSughosha <Sughosha@proton.me>2023-06-16 07:10:42 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-06 01:03:53 -0400
commit3c2b892d2957298da37599321c24d172e8067eba (patch)
treec0a8c6fbe7cc6e6d9f973c69a92843c27aee8dc1
parent87dab3e36b336bd9b972536e0031dbac82f0f38d (diff)
gnu: rtaudio: Update to 5.2.0.
* gnu/packages/audio.scm (rtaudio): Update to 5.2.0. [#:phases]: Delete argument. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/audio.scm16
1 files changed, 2 insertions, 14 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 06a68f2982..48a4f8d536 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2832,7 +2832,7 @@ implementation of the Open Sound Control (@dfn{OSC}) protocol.")
(define-public rtaudio
(package
(name "rtaudio")
- (version "5.1.0")
+ (version "5.2.0")
(source
(origin
(method git-fetch)
@@ -2841,20 +2841,8 @@ implementation of the Open Sound Control (@dfn{OSC}) protocol.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "156c2dgh6jrsyfn1y89nslvaxm4yifmxridsb708yvkaym02w2l8"))))
+ (base32 "189xphhf0winf8b60dx1kk2biz811wk6ps44br7l1lyfhymxcjmi"))))
(build-system cmake-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; The header that pkg-config expects is include/rtaudio/RtAudio.h,
- ;; but this package installs it as include/RtAudio.h by default.
- (add-after 'install 'fix-inc-path
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (inc (string-append out "/include")))
- (mkdir-p (string-append inc "/rtaudio"))
- (rename-file (string-append inc "/RtAudio.h")
- (string-append inc "/rtaudio/RtAudio.h"))))))))
(native-inputs
(list pkg-config))
(inputs