summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-08-10 19:43:10 +0800
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-06 01:25:30 -0400
commite99279aa2706ff2471d234db4e3ad0c67239c2dd (patch)
treee227584ed3f899d878c7045809b8de74030b39d5
parent701041aac1fdd74fc036c83285596aae4f47cb39 (diff)
gnu: Add go-github-com-cespare-mph.
* gnu/packages/golang.scm (go-github-com-cespare-mph): New variable. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 524d7ff66d..7e294f9eee 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7616,6 +7616,29 @@ non-UTF-friendly sources.")
encoding in Go.")
(license license:bsd-3)))
+(define-public go-github-com-cespare-mph
+ (package
+ (name "go-github-com-cespare-mph")
+ (version "0.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cespare/mph")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0mvd6bkvf3i3555kqkkr3k9jd4c25scjq4xad35sxpny8f72nbg1"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/cespare/mph"))
+ (home-page "https://github.com/cespare/mph")
+ (synopsis "Minimal perfect hashing in Go")
+ (description
+ "@code{mph} is a Go package that implements a minimal perfect hash table
+over strings.")
+ (license license:expat)))
+
(define-public go-github-com-gdamore-tcell
(let ((commit "aaadc574a6ed8dc3abe56036ca130dcee1ee6b6e")
(version "1.1.2")